aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Krysik <ptrkrysik@gmail.com>2017-01-03 08:01:23 +0100
committerPiotr Krysik <ptrkrysik@gmail.com>2017-01-03 08:01:23 +0100
commit70c25a112a3a8637dccafb278ca27a96ba950117 (patch)
tree087a08f8fcd582fa4950325ebf8823ea33652f65 /CMakeLists.txt
parent25ae3e2066e589f7faf2ddf9b1811697583233ac (diff)
Changes in decoding:
-copied decoding routines from libosmocore to gr-gsm, -made cmake files entries for new source files and added linking with libosmocodec, -moved sch.c file to decoding folder.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 9 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 11d589d..6e85472 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -107,7 +107,8 @@ find_package(Volk)
find_package(CppUnit)
find_package(Doxygen)
find_package(Libosmocore)
-find_package(Libosmocoding)
+#find_package(Libosmocoding)
+find_package(Libosmocodec)
if(NOT GNURADIO_RUNTIME_FOUND)
message(FATAL_ERROR "GnuRadio Runtime required to compile gr-gsm")
@@ -121,9 +122,13 @@ endif()
if(NOT LIBOSMOCORE_FOUND)
message(FATAL_ERROR "Libosmocore required to compile gr-gsm")
endif()
-if(NOT LIBOSMOCODING_FOUND)
- message(FATAL_ERROR "Libosmocoding required to compile gr-gsm")
-endif()
+message( dupa 2!!! )
+#if(NOT LIBOSMOCODEC_FOUND)
+# message(FATAL_ERROR "Libosmocodec required to compile gr-gsm")
+#endif()
+#if(NOT LIBOSMOCODING_FOUND)
+# message(FATAL_ERROR "Libosmocoding required to compile gr-gsm")
+#endif()
########################################################################
# Setup doxygen option