aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Krysik <ptrkrysik@gmail.com>2016-07-15 13:39:19 +0200
committerPiotr Krysik <ptrkrysik@gmail.com>2016-07-15 13:39:19 +0200
commit4a1ca9897b88390739dcfb12ba9cb0bfd019ccdc (patch)
tree641dbf136a483808e0ed4b1f24a0eefaf0052528 /CMakeLists.txt
parentf7b3fc236d9ff59095cba2b9b1a138e3c801fdac (diff)
Changes in the buildsystem for new blocks
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3e14c82..5832d42 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -101,7 +101,7 @@ set(GRC_BLOCKS_DIR ${GR_PKG_DATA_DIR}/grc/blocks)
########################################################################
# Find gnuradio build dependencies
########################################################################
-set(GR_REQUIRED_COMPONENTS RUNTIME PMT)
+set(GR_REQUIRED_COMPONENTS RUNTIME FILTER PMT)
find_package(Gnuradio)
find_package(Volk)
find_package(CppUnit)
@@ -140,14 +140,14 @@ include_directories(
${CMAKE_BINARY_DIR}/include
${Boost_INCLUDE_DIRS}
${CPPUNIT_INCLUDE_DIRS}
- ${GNURADIO_RUNTIME_INCLUDE_DIRS}
+ ${GNURADIO_ALL_INCLUDE_DIRS}
${LIBOSMOCORE_INCLUDE_DIR}
)
link_directories(
${Boost_LIBRARY_DIRS}
${CPPUNIT_LIBRARY_DIRS}
- ${GNURADIO_RUNTIME_LIBRARY_DIRS}
+ ${GNURADIO_ALL_LIBRARY_DIRS}
)
# Set component parameters