aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVasil Velichkov <vvvelichkov@gmail.com>2018-06-05 19:48:46 +0300
committerPiotr Krysik <ptrkrysik@gmail.com>2018-09-13 15:35:44 +0200
commit9d211b3da33bba3e1dc92b525477524b575c1aa8 (patch)
tree9370e9c4ce01096d6f41fc5760c59b904461beeb /CMakeLists.txt
parentbbc8af53e8c7b03b25bfd50a3dabf1ca2ee3a34d (diff)
Add LOCAL_OSMOCOM cmake option
When set the gr-gsm will be compiled and linked with the local copies of the osmocom libraries.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f032206..bfbfe1a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -136,6 +136,8 @@ find_package(Gnuradio)
find_package(Volk)
find_package(CppUnit)
#find_package(Doxygen)
+
+option(LOCAL_OSMOCOM "Build with local osmocom libraries" OFF)
find_package(Libosmocore)
find_package(Libosmocodec)
find_package(Libosmocoding)
@@ -153,7 +155,12 @@ endif()
if(NOT CPPUNIT_FOUND)
message(FATAL_ERROR "CppUnit required to compile gr-gsm")
endif()
-if(NOT LIBOSMOCORE_FOUND OR NOT LIBOSMOCODEC_FOUND)
+if(LOCAL_OSMOCOM)
+ message(STATUS "Compiling with local osmocom libraries")
+ unset(LIBOSMOCORE_FOUND)
+ unset(LIBOSMOCODEC_FOUND)
+ unset(LIBOSMOCODING_FOUND)
+elseif(NOT LIBOSMOCORE_FOUND OR NOT LIBOSMOCODEC_FOUND)
message(STATUS "Compiling local version of libosmocore")
elseif(NOT LIBOSMOCODING_FOUND)
message(STATUS "Compiling local version of libosmocoding")