aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Krysik <ptrkrysik@gmail.com>2017-09-24 11:26:54 +0200
committerPiotr Krysik <ptrkrysik@gmail.com>2017-09-24 11:26:54 +0200
commit59e4fe6aa4546b311f923e32927b3ad178e74541 (patch)
tree46962e4a5d35d44cc7cf75ffaf3f936d07d4f537 /CMakeLists.txt
parente18b431c4b51db43332eb8621ca06b6abd38a777 (diff)
Getting rid of cmake policy warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 83d50fc..887f49d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,6 +36,25 @@ set(CMAKE_BUILD_TYPE ${CMAKE_BUILD_TYPE} CACHE STRING "")
list(APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/Modules)
########################################################################
+# Set cmake policies.
+########################################################################
+# This will suppress developer warnings during the cmake process that can occur
+# if a newer cmake version than the minimum is used.
+
+if(POLICY CMP0026)
+ cmake_policy(SET CMP0026 OLD)
+endif()
+if(POLICY CMP0043)
+ cmake_policy(SET CMP0043 OLD)
+endif()
+if(POLICY CMP0045)
+ cmake_policy(SET CMP0045 OLD)
+endif()
+if(POLICY CMP0046)
+ cmake_policy(SET CMP0046 OLD)
+endif()
+
+########################################################################
# Set version variables (
########################################################################