aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVasil Velichkov <vvvelichkov@gmail.com>2018-04-30 20:01:16 +0300
committerPiotr Krysik <ptrkrysik@gmail.com>2018-09-13 15:35:44 +0200
commit0658bd424d55f32359ff284f38e70eef59820f25 (patch)
treedfa8763c04c1154cd09affb2f52e8d0ba6ddaa12 /CMakeLists.txt
parentb4a0acf9f54120634af5f0672a6effde8801fdb3 (diff)
Check that pkg-config is available
It is needed to properly detect the grcc full path See also 3f6ab15a7a5492391ca0f94bd0a5586c1735f8db
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6689d9d..ca71fff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -140,7 +140,9 @@ find_package(Libosmocore)
find_package(Libosmocodec)
find_package(Libosmocoding)
-
+if(NOT PKG_CONFIG_FOUND)
+ message(FATAL_ERROR "pkg-config is required to compile gr-gsm")
+endif()
if(NOT GNURADIO_RUNTIME_FOUND)
message(FATAL_ERROR "GnuRadio Runtime required to compile gr-gsm")
endif()