aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVasil Velichkov <vvvelichkov@gmail.com>2018-04-30 20:01:16 +0300
committerPiotr Krysik <pkrysik@elka.pw.edu.pl>2018-06-18 15:11:17 +0200
commit9b5519db84548040a2bda7a8939c1f894843f879 (patch)
tree2fa478d703cca6236d088ec27e21f658a06983c2 /CMakeLists.txt
parent8c4eefb205a914c92df0deaf89ffa8338c0cb179 (diff)
Check that pkg-config is available
It is needed to properly detect the grcc full path See also 3f6ab15a7a5492391ca0f94bd0a5586c1735f8db
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6689d9d..ca71fff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -140,7 +140,9 @@ find_package(Libosmocore)
find_package(Libosmocodec)
find_package(Libosmocoding)
-
+if(NOT PKG_CONFIG_FOUND)
+ message(FATAL_ERROR "pkg-config is required to compile gr-gsm")
+endif()
if(NOT GNURADIO_RUNTIME_FOUND)
message(FATAL_ERROR "GnuRadio Runtime required to compile gr-gsm")
endif()