aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f838fa4..4f7c4be 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -14,6 +14,7 @@ check_PROGRAMS = \
procqueue/pq_test \
io/pq_file_test \
io/pq_rtp_test \
+ ecu/ecu_fr_test \
$(NULL)
procqueue_pq_test_SOURCES = procqueue/pq_test.c
@@ -40,6 +41,14 @@ io_pq_rtp_test_LDADD = \
$(TALLOC_LIBS) \
$(NULL)
+ecu_ecu_fr_test_SOURCES = ecu/ecu_fr_test.c
+ecu_ecu_fr_test_LDADD = \
+ $(top_builddir)/src/libosmogapk.la \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOCODEC_LIBS) \
+ $(TALLOC_LIBS) \
+ $(NULL)
+
# The `:;' works around a Bash 3.2 bug when the output is not writeable.
$(srcdir)/package.m4: $(top_srcdir)/configure.ac
:;{ \
@@ -66,6 +75,7 @@ EXTRA_DIST = \
EXTRA_DIST += \
procqueue/pq_test.ok \
+ ecu/ecu_fr_test.ok \
io/pq_file_test.ok \
io/pq_rtp_test.ok \
io/io_sample.txt \