aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2013-02-11 11:34:58 +0100
committerHarald Welte <laforge@gnumonks.org>2013-02-11 11:38:23 +0100
commitce94d971e1223626c96ad32373ea4ff034233b50 (patch)
treebbe05c72550d305c50e07528547cb730f59bc4f7 /src/Makefile.am
parentf7f0c91ca8c6cae331fa65db71f8c32502fad256 (diff)
gapk: Add support for RTP input/output streams
Instead of having only file-based I/O, this enables gapk to receive and send RTP streams, e.g. from live GSM network equipment like sysmoBTS/nanoBTS. Support is currently simplistic. On transmit, there is hard-coded codec type of full-rate GSM. On receive-side, we should auto-detect the format based on frame size and/or payload type, but we don't do that yet at all.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 9 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 55a6a5d..c17dd3f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,14 +1,18 @@
INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
-AM_CFLAGS=-Wall $(LIBOSMOCODEC_CFLAGS) ${OPENCORE_AMRNB_CFLAGS}
-AM_LDFLAGS=$(LIBOSMOCODEC_LIBS) ${OPENCORE_AMRNB_LIBS} ${LIBGSM_LIBS}
+AM_CFLAGS=-Wall $(LIBOSMOCODEC_CFLAGS) $(LIBOSMOCORE_CFLAGS) \
+ ${OPENCORE_AMRNB_CFLAGS}
+AM_LDFLAGS=$(LIBOSMOCODEC_LIBS) $(LIBOSMOCORE_LIBS) \
+ ${OPENCORE_AMRNB_LIBS} ${LIBGSM_LIBS}
-bin_PROGRAMS = gapk
-gapk_SOURCES = main.c \
- procqueue.c pq_file.c pq_format.c pq_codec.c \
+COM_SOURCES = procqueue.c pq_file.c pq_format.c pq_codec.c pq_rtp.c \
formats.c fmt_amr.c fmt_gsm.c fmt_hr_ref.c fmt_racal.c \
fmt_rawpcm.c fmt_ti.c \
codecs.c codec_pcm.c codec_hr.c codec_fr.c codec_efr.c
+bin_PROGRAMS = gapk
+
+gapk_SOURCES = main.c $(COM_SOURCES)
+
if ENABLE_GSMHR
gapk_LDADD = $(top_builddir)/libgsmhr/libgsmhr.la
endif