aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2014-05-08 19:18:01 +0200
committerHarald Welte <laforge@gnumonks.org>2014-05-08 19:18:01 +0200
commit7a04624563ac72b7237e39d6fcee5dab96f4d948 (patch)
treee97aa7567abe2c3f205c327ff3ef5d5d160fbd2e /src/Makefile.am
parent8b5e0c7b81cba9f064bed97dc743e5a9a13818f1 (diff)
Add cycle benchmarking support
This enables benchmarking of the codec. It will print the amount of CPU cycles needed for encoding/decoding a single 20ms frame on average.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 818f215..788d425 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,7 +6,7 @@ AM_LDFLAGS=$(LIBOSMOCODEC_LIBS) $(LIBOSMOCORE_LIBS) \
COM_SOURCES = procqueue.c pq_file.c pq_format.c pq_codec.c pq_rtp.c \
formats.c fmt_amr.c fmt_gsm.c fmt_hr_ref.c fmt_racal.c \
- fmt_rawpcm.c fmt_ti.c \
+ fmt_rawpcm.c fmt_ti.c benchmark.c \
codecs.c codec_pcm.c codec_hr.c codec_fr.c codec_efr.c
bin_PROGRAMS = gapk