aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSylvain Munaut <tnt@246tNt.com>2010-11-12 17:10:44 +0100
committerSylvain Munaut <tnt@246tNt.com>2010-11-12 20:36:14 +0100
commit0d2a82c312056046ecafba318e60a930df395ea2 (patch)
tree429412e84a66cf226528fa8e44ba1f154bce76d2 /configure.ac
parent4604976a5facb2105bde3214b31ba609df65b939 (diff)
[1/4] HR support: Add autotools skeleton for libgsmhr
Not functional yet, just the autotools magic to make a library Signed-off-by: Sylvain Munaut <tnt@246tNt.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 39c2f76..eb2c332 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,12 +12,39 @@ AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_FILES([
Makefile
src/Makefile
+ libgsmhr/Makefile
include/Makefile
include/gapk/Makefile
+ include/gsmhr/Makefile
])
+# Options
+AC_ARG_ENABLE(gsmhr,
+ [AS_HELP_STRING(
+ [--disable-gsmhr],
+ [Disable support for GSM HR codec using reference code]
+ )],
+ [enable_gsmhr=0], [enable_gsmhr=1])
+AM_CONDITIONAL(ENABLE_GSMHR, test "x$enable_gsmhr" = "x1")
+if test "x$enable_gsmhr" = "x1"; then
+ AC_DEFINE(HAVE_LIBGSMHR, 1, [Define to 1 if libgsmhr is available])
+fi
+
+# Check for -fvisibility support
+# (The following test is taken from WebKit's webkit.m4)
+saved_CFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS -fvisibility=hidden "
+AC_MSG_CHECKING([if ${CC} supports -fvisibility=hidden])
+AC_COMPILE_IFELSE([char foo;],
+ [ AC_MSG_RESULT([yes])
+ SYMBOL_VISIBILITY="-fvisibility=hidden"],
+ AC_MSG_RESULT([no]))
+CFLAGS="$saved_CFLAGS"
+AC_SUBST(SYMBOL_VISIBILITY)
+
# Checks for programs.
AC_PROG_CC
+AC_PROG_LIBTOOL
# Checks for libraries.
# libosmocore (codec module)