aboutsummaryrefslogtreecommitdiffstats
path: root/rpm-local/spec/fdupes/fdupes.spec
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2020-05-19 16:27:10 +0200
committerOliver Smith <osmith@sysmocom.de>2020-05-19 16:27:10 +0200
commit6f9a5008f9085764b0bc0a49743562b45527b85d (patch)
tree53efafa87eb48e7496d47d85d666f9c6d57a606a /rpm-local/spec/fdupes/fdupes.spec
parent1f579be648e803075376638aa7e286722f431aed (diff)
build.sh: add fdupes
Diffstat (limited to 'rpm-local/spec/fdupes/fdupes.spec')
-rw-r--r--rpm-local/spec/fdupes/fdupes.spec67
1 files changed, 67 insertions, 0 deletions
diff --git a/rpm-local/spec/fdupes/fdupes.spec b/rpm-local/spec/fdupes/fdupes.spec
new file mode 100644
index 0000000..65238ad
--- /dev/null
+++ b/rpm-local/spec/fdupes/fdupes.spec
@@ -0,0 +1,67 @@
+#
+# spec file for package fdupes
+#
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
+#
+
+# Upstream calls this version 1.6.1, but that version number is *lower* than
+# previously released ones, like 1.51, so we mangle the number to keep
+# continuity: https://github.com/adrianlopezroche/fdupes/issues/74.
+%global upstream_version 1.6.1
+
+%{?!_rpmmacrodir:%define _rpmmacrodir /usr/lib/rpm/macros.d}
+
+Name: fdupes
+Version: 1.61
+Release: 0
+Summary: Identifying or deleting duplicate files
+License: MIT
+Group: Productivity/Archiving/Compression
+Url: https://github.com/adrianlopezroche/fdupes
+Source0: https://github.com/adrianlopezroche/fdupes/archive/v%{upstream_version}.tar.gz#/%{name}-%{upstream_version}.tar.gz
+Source1: macros.fdupes
+#PATCH-FIX-SUSE: fix patch according distro's needs
+Patch0: fdupes-makefile.patch
+BuildRoot: %{_tmppath}/%{name}-%{version}-build
+
+%description
+FDUPES is a program for identifying or deleting duplicate files
+residing within specified directories.
+
+%prep
+%setup -q -n %{name}-%{upstream_version}
+%patch0
+
+%build
+make %{?_smp_mflags} COMPILER_OPTIONS="%{optflags}"
+
+%install
+install -D -m755 %{name} %{buildroot}%{_bindir}/%{name}
+install -D -m644 %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
+install -D -m644 %{SOURCE1} %{buildroot}%{_rpmmacrodir}/macros.%{name}
+
+%check
+./%{name} testdir
+./%{name} --omitfirst testdir
+./%{name} --recurse testdir
+./%{name} --size testdir
+
+%files
+%defattr(-, root, root)
+%doc CHANGES
+%{_bindir}/%{name}
+%{_mandir}/man1/%{name}.1*
+%{_rpmmacrodir}/macros.%{name}
+
+%changelog