aboutsummaryrefslogtreecommitdiffstats
path: root/debian-stretch-jenkins
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2020-08-15 15:42:08 +0200
committerlynxis lazus <lynxis@fe80.eu>2020-08-17 08:34:13 +0000
commit7bc7dccd0b42f57a343ff51d7d6f0114f963d77b (patch)
tree69b970825e2fd6f6756080436001d10f07f9d186 /debian-stretch-jenkins
parentcc1620eac8844389c4d50f7a72176bfe8f7252af (diff)
debian-stretch-jenkins: install osmo-python-tests for python2
osmo-python-tests for python2 is being used when building old releases. Change-Id: I63b3e92e745a664d5d0168c718daddae83c20df5
Diffstat (limited to 'debian-stretch-jenkins')
-rw-r--r--debian-stretch-jenkins/Dockerfile20
1 files changed, 17 insertions, 3 deletions
diff --git a/debian-stretch-jenkins/Dockerfile b/debian-stretch-jenkins/Dockerfile
index 158f7d7..e73b7ae 100644
--- a/debian-stretch-jenkins/Dockerfile
+++ b/debian-stretch-jenkins/Dockerfile
@@ -100,6 +100,10 @@ RUN \
python3-setuptools \
python3-usb \
python3-yaml \
+ python2.7 \
+ python-pip \
+ python-setuptools \
+ python-yaml \
rsync \
sdcc \
sqlite3 \
@@ -127,9 +131,19 @@ RUN useradd --uid=1000 build
RUN mkdir /build
RUN chown build:build /build
-# Install osmo-python-tests
-ADD http://git.osmocom.org/python/osmo-python-tests/patch /tmp/commit
-RUN git clone git://git.osmocom.org/python/osmo-python-tests && cd osmo-python-tests && ./contrib/jenkins.sh
+# Install osmo-python-tests for python2 (when building old tags again new releases)
+ARG OSMO_PYTHON2_TESTS_COMMIT=fb4b813d4df62b7b2445bdced961eb1847267eed
+ADD http://git.osmocom.org/python/osmo-python-tests/patch/?id=$OSMO_PYTHON2_TESTS_COMMIT /tmp/osmo-python-tests2-commit
+RUN git clone https://git.osmocom.org/python/osmo-python-tests osmo-python-tests2 && \
+ cd osmo-python-tests2 && \
+ git checkout $OSMO_PYTHON2_TESTS_COMMIT && \
+ python2 setup.py clean build install
+
+# Install osmo-python-tests for python3
+ADD http://git.osmocom.org/python/osmo-python-tests/patch /tmp/osmo-python-tests3-commit
+RUN git clone https://git.osmocom.org/python/osmo-python-tests osmo-python-tests3 && \
+ cd osmo-python-tests3 && \
+ python3 setup.py clean build install
# Set a UTF-8 locale
RUN sed -i -e 's/# en_US.UTF-8 UTF-8/en_US.UTF-8 UTF-8/' /etc/locale.gen && \