aboutsummaryrefslogtreecommitdiffstats
path: root/debian-stretch-jenkins
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2021-01-11 14:42:07 +0100
committerlaforge <laforge@osmocom.org>2021-01-12 08:26:25 +0000
commit8f2210f528cbe0a238eb2b14e14db7ab879e0d89 (patch)
tree34dbfbe889832bed6ea53482ae983146b7bf30d1 /debian-stretch-jenkins
parent663c77203b4eda23b3da1affea46c0c2880b9621 (diff)
debian-stretch-jenkins, osmo-gsm-tester: add osmo-ci
Clone osmo-ci.git, and install all files from scripts/* to /usr/local/bin. Together with osmo-ci I45bd7ea56849dab839a98cfd52806f7cd288094e, this will make overwriting PATH obsolete. Related: OS#4911 Change-Id: I0820f13cd740f7d4a8999d279cef6ae293a67d81
Diffstat (limited to 'debian-stretch-jenkins')
-rw-r--r--debian-stretch-jenkins/Dockerfile8
1 files changed, 8 insertions, 0 deletions
diff --git a/debian-stretch-jenkins/Dockerfile b/debian-stretch-jenkins/Dockerfile
index 6455a21..1f87445 100644
--- a/debian-stretch-jenkins/Dockerfile
+++ b/debian-stretch-jenkins/Dockerfile
@@ -148,6 +148,14 @@ RUN git clone https://git.osmocom.org/python/osmo-python-tests osmo-python-tests
cd osmo-python-tests3 && \
python3 setup.py clean build install
+# Install osmo-ci.git/scripts to /usr/local/bin
+ADD http://git.osmocom.org/osmo-ci/patch /tmp/osmo-ci-commit
+RUN git clone https://git.osmocom.org/osmo-ci osmo-ci && \
+ cp -v $(find osmo-ci/scripts \
+ -maxdepth 1 \
+ -type f ) \
+ /usr/local/bin
+
# Set a UTF-8 locale
RUN sed -i -e 's/# en_US.UTF-8 UTF-8/en_US.UTF-8 UTF-8/' /etc/locale.gen && \
dpkg-reconfigure --frontend=noninteractive locales && \