aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-08-20 12:54:01 +0200
committerHarald Welte <laforge@gnumonks.org>2017-08-20 12:54:01 +0200
commit19c9c2b8b22f87e9a5ad9ddfe2d89c82ab65d3bd (patch)
tree8489e601de36065493b3bbe0e6bd729836636c9d
parent453f690c9766a566b6d7ef62b281e2cf4ffc9f09 (diff)
ggsn: Use SIGINT as this is handled in ggsn for fast termination
For some reason, it appears that if docker sends SIGTERM the default action (kernel auto terminate) is not installed, but it expects the program to handle it directly. Let's tell docker to use SIGINT as this is what ggsn always handled.
-rw-r--r--osmo-ggsn-master/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/osmo-ggsn-master/Makefile b/osmo-ggsn-master/Makefile
index 3c24c86..5d6a495 100644
--- a/osmo-ggsn-master/Makefile
+++ b/osmo-ggsn-master/Makefile
@@ -1,3 +1,3 @@
-RUN_ARGS?=--cap-add=NET_ADMIN --device /dev/net/tun:/dev/net/tun --sysctl net.ipv6.conf.all.disable_ipv6=0--rm --network sigtran --ip 172.18.0.201 -v ggsn-vol:/data
+RUN_ARGS?=--cap-add=NET_ADMIN --device /dev/net/tun:/dev/net/tun --sysctl net.ipv6.conf.all.disable_ipv6=0--rm --network sigtran --ip 172.18.0.201 -v ggsn-vol:/data --stop-signal SIGINT
include ../make/Makefile