aboutsummaryrefslogtreecommitdiffstats
path: root/editline/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'editline/configure.in')
-rwxr-xr-xeditline/configure.in21
1 files changed, 20 insertions, 1 deletions
diff --git a/editline/configure.in b/editline/configure.in
index 72ae9180b..dcef07a91 100755
--- a/editline/configure.in
+++ b/editline/configure.in
@@ -31,7 +31,26 @@ case "${host}" in
*-*-freebsd*)
ABI="elf"
;;
- *-*-linux*)
+ *-*-linux* | *cygwin*)
+ cyg="$(echo ${host} | sed -e c\cygwin)"
+ if [ ${cyg} = cygwin ]; then \
+ echo "cygwin detected"; \
+ S_CFLAGS=""; \
+ echo "/* cygdef.h. Generated automatically by configure. */
+#ifndef _CYGDEF_H_
+#define _CYGDEF_H_ 1
+#include <sys/ioctl.h>
+#define __linux__ 1
+
+
+typedef void (*sig_t)(int);
+
+
+#endif /* _CYGDEF_H_ */" > cygdef.h; \
+ echo "
+ #define CYGWIN 1
+" > confdefs.h; \
+ fi
ABI="elf"
;;
*-*-netbsd*)