aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f00edc471..8282f9f5f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,8 +38,10 @@ case "${host_os}" in
;;
esac
-if test ${localstatedir} = '${prefix}/var'; then
- localstatedir=/var
+if test ${prefix} = ${ac_default_prefix} || test ${prefix} = 'NONE'; then
+ if test ${localstatedir} = '${prefix}/var'; then
+ localstatedir=/var
+ fi
fi
BUILD_PLATFORM=${build}