aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 62515088d..17cba0205 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,8 +57,10 @@ case "${host_os}" in
;;
esac
-if test ${localstatedir} = '${prefix}/var'; then
- localstatedir=/var
+if test ${prefix} = ${ac_default_prefix} || test ${prefix} = 'NONE'; then
+ if test ${localstatedir} = '${prefix}/var'; then
+ localstatedir=/var
+ fi
fi
BUILD_PLATFORM=${build}