aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7da3577ba..036f01dad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1580,7 +1580,6 @@ AC_LANG_PUSH(C++)
if test "${USE_VPB}" != "no"; then
AC_MSG_CHECKING(for vpb_open in -lvpb)
saved_libs="${LIBS}"
- saved_cflags="${CFLAGS}"
saved_cppflags="${CPPFLAGS}"
if test "x${VPB_DIR}" != "x"; then
if test -d ${VPB_DIR}/lib; then
@@ -1592,7 +1591,7 @@ if test "${USE_VPB}" != "no"; then
CPPFLAGS="${CPPFLAGS} -I${VPB_DIR}/include"
fi
LIBS="${PTHREAD_LIBS} ${LIBS} -lvpb"
- CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
+ CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS}"
AC_LINK_IFELSE(
[
AC_LANG_PROGRAM(
@@ -1606,7 +1605,6 @@ if test "${USE_VPB}" != "no"; then
ac_cv_lib_vpb_vpb_open="no"
]
)
- CFLAGS="${saved_cflags}"
LIBS="${saved_libs}"
CPPFLAGS="${saved_cppflags}"
if test "${ac_cv_lib_vpb_vpb_open}" = "yes"; then