aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 7 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index f86d9965b..ac6505a5f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -932,22 +932,13 @@ if test "${USE_CURL}" != "no"; then
AC_PATH_TOOL([CURL], [curl-config], No)
if test ! x"${CURL}" = xNo; then
# check for version
- if test "${host_os}" = "SunOS"; then
- if [[ 0x`curl-config --vernum` -ge 0x70907 ]]; then
- CURL_INCLUDE=$(${CURL} --cflags)
- CURL_LIB=$(${CURL} --libs)
- PBX_CURL=1
- AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
- fi
- else
- if [[[ 0x`curl-config --vernum` -ge 0x70907 ]]]; then
- CURL_INCLUDE=$(${CURL} --cflags)
- CURL_LIB=$(${CURL} --libs)
- PBX_CURL=1
- AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
- fi
- fi
- fi
+ if test $(printf "%d" 0x$(curl-config --vernum)) -ge $(printf "%d" 0x070907); then
+ CURL_INCLUDE=$(${CURL} --cflags)
+ CURL_LIB=$(${CURL} --libs)
+ PBX_CURL=1
+ AC_DEFINE([HAVE_CURL], 1, [Define if your system has the curl libraries.])
+ fi
+ fi
fi
AC_CONFIG_FILES([build_tools/menuselect-deps makeopts channels/h323/Makefile])