aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac60
1 files changed, 10 insertions, 50 deletions
diff --git a/configure.ac b/configure.ac
index 490e32f92..14b2e464c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -246,6 +246,11 @@ AST_EXT_LIB_SETUP([PGSQL], [PostgreSQL], [postgres])
AST_EXT_LIB_SETUP([POPT], [popt], [popt])
AST_EXT_LIB_SETUP([PORTAUDIO], [PortAudio], [portaudio])
AST_EXT_LIB_SETUP([PRI], [ISDN PRI], [pri])
+AST_EXT_LIB_SETUP_DEPENDENT([PRI_VERSION], [ISDN PRI get_version], [PRI], [pri])
+AST_EXT_LIB_SETUP_DEPENDENT([PRI_INBANDDISCONNECT], [ISDN PRI set_inbanddisconnect], [PRI], [pri])
+AST_EXT_LIB_SETUP_DEPENDENT([PRI_PROG_W_CAUSE], [ISDN progress with cause], [PRI], [pri])
+AST_EXT_LIB_SETUP_DEPENDENT([PRI_SERVICE_MESSAGES], [ISDN service messages], [PRI], [pri])
+AST_EXT_LIB_SETUP_DEPENDENT([PRI_REVERSE_CHARGE], [ISDN reverse charge], [PRI], [pri])
AST_EXT_LIB_SETUP([RESAMPLE], [LIBRESAMPLE], [resample])
AST_EXT_LIB_SETUP([SPANDSP], [SPANDSP], [spandsp])
AST_EXT_LIB_SETUP([SS7], [ISDN SS7], [ss7])
@@ -257,6 +262,7 @@ AST_EXT_LIB_SETUP([SDL_IMAGE], [Sdl Image library], [SDL_image])
AST_EXT_LIB_SETUP([SPEEX], [Speex], [speex])
AST_EXT_LIB_SETUP([SPEEX_PREPROCESS], [Speex preprocess routines], [speex])
AST_EXT_LIB_SETUP([SPEEXDSP], [Speexdsp], [speexdsp])
+AST_EXT_LIB_SETUP_DEPENDENT([SPEEX_PREPROCESS], [speex_preprocess_ctl], [], [speex])
AST_EXT_LIB_SETUP([SQLITE], [SQLite], [sqlite])
AST_EXT_LIB_SETUP([SQLITE3], [SQLite], [sqlite3])
AST_EXT_LIB_SETUP([SUPPSERV], [mISDN Supplemental Services], [suppserv])
@@ -326,9 +332,11 @@ AC_FUNC_STRNLEN
AC_FUNC_STRTOD
AC_FUNC_UTIME_NULL
AC_FUNC_VPRINTF
-AC_CHECK_FUNCS([asprintf atexit dup2 eaccess endpwent euidaccess ftruncate getcwd gethostbyname gethostname getloadavg gettimeofday inet_ntoa isascii localtime_r memchr memmove memset mkdir munmap putenv re_comp regcomp select setenv socket strcasecmp strcasestr strchr strcspn strdup strerror strlcat strlcpy strncasecmp strndup strnlen strrchr strsep strspn strstr strtol strtoq unsetenv utime vasprintf])
+AC_CHECK_FUNCS([asprintf atexit dup2 eaccess endpwent euidaccess ftruncate getcwd gethostbyname gethostname getloadavg gettimeofday glob inet_ntoa isascii localtime_r memchr memmove memset mkdir munmap putenv re_comp regcomp select setenv socket strcasecmp strcasestr strchr strcspn strdup strerror strlcat strlcpy strncasecmp strndup strnlen strrchr strsep strspn strstr strtod strtol strtold strtoq unsetenv utime vasprintf])
-AC_CHECK_FUNCS([glob])
+# BSD might not have exp2, and/or log2
+AC_CHECK_LIB([m], [sqrt])
+AC_CHECK_FUNCS([exp2l log2l exp10l log10l sinl cosl tanl asinl acosl atanl atan2l powl sqrtl rintl expl logl remainderl fmodl roundl truncl floorl ceill exp2 log2 exp10 log10 sin cos tan asin acos atan atan2 pow rint exp log remainder fmod round trunc floor ceil])
AC_MSG_CHECKING(for timersub in time.h)
AC_LINK_IFELSE(
@@ -610,54 +618,6 @@ fi
AST_C_DEFINE_CHECK([DAHDI], [DAHDI_CODE], [dahdi/user.h])
-# BSD might not have exp2, and/or log2
-AST_EXT_LIB_CHECK([EXP2L], [m], [exp2l])
-AST_EXT_LIB_CHECK([LOG2L], [m], [log2l])
-AST_EXT_LIB_CHECK([EXP10L], [m], [exp10l])
-AST_EXT_LIB_CHECK([LOG10L], [m], [log10l])
-AST_EXT_LIB_CHECK([SINL], [m], [sinl])
-AST_EXT_LIB_CHECK([COSL], [m], [cosl])
-AST_EXT_LIB_CHECK([TANL], [m], [tanl])
-AST_EXT_LIB_CHECK([ASINL], [m], [asinl])
-AST_EXT_LIB_CHECK([ACOSL], [m], [acosl])
-AST_EXT_LIB_CHECK([ATANL], [m], [atanl])
-AST_EXT_LIB_CHECK([ATAN2L], [m], [atan2l])
-AST_EXT_LIB_CHECK([POWL], [m], [powl])
-AST_EXT_LIB_CHECK([SQRTL], [m], [sqrtl])
-AST_EXT_LIB_CHECK([RINTL], [m], [rintl])
-AST_EXT_LIB_CHECK([EXPL], [m], [expl])
-AST_EXT_LIB_CHECK([LOGL], [m], [logl])
-AST_EXT_LIB_CHECK([REMAINDERL], [m], [remainderl])
-AST_EXT_LIB_CHECK([FMODL], [m], [fmodl])
-AST_EXT_LIB_CHECK([ROUNDL], [m], [roundl])
-AST_EXT_LIB_CHECK([TRUNCL], [m], [truncl])
-AST_EXT_LIB_CHECK([STRTOLD], [c], [strtold], [stdlib.h])
-AST_EXT_LIB_CHECK([FLOORL], [m], [floorl])
-AST_EXT_LIB_CHECK([CEILL], [m], [ceill])
-AST_EXT_LIB_CHECK([EXP2], [m], [exp2])
-AST_EXT_LIB_CHECK([LOG2], [m], [log2])
-AST_EXT_LIB_CHECK([EXP10], [m], [exp10])
-AST_EXT_LIB_CHECK([LOG10], [m], [log10])
-AST_EXT_LIB_CHECK([SIN], [m], [sin])
-AST_EXT_LIB_CHECK([COS], [m], [cos])
-AST_EXT_LIB_CHECK([TAN], [m], [tan])
-AST_EXT_LIB_CHECK([ASIN], [m], [asin])
-AST_EXT_LIB_CHECK([ACOS], [m], [acos])
-AST_EXT_LIB_CHECK([ATAN], [m], [atan])
-AST_EXT_LIB_CHECK([ATAN2], [m], [atan2])
-AST_EXT_LIB_CHECK([POW], [m], [pow])
-AST_EXT_LIB_CHECK([SQRT], [m], [sqrt])
-AST_EXT_LIB_CHECK([RINT], [m], [rint])
-AST_EXT_LIB_CHECK([EXP], [m], [exp])
-AST_EXT_LIB_CHECK([LOG], [m], [log])
-AST_EXT_LIB_CHECK([REMAINDER], [m], [remainder])
-AST_EXT_LIB_CHECK([FMOD], [m], [fmod])
-AST_EXT_LIB_CHECK([ROUND], [m], [round])
-AST_EXT_LIB_CHECK([TRUNC], [m], [trunc])
-AST_EXT_LIB_CHECK([STRTOD], [c], [strtod], [stdlib.h])
-AST_EXT_LIB_CHECK([FLOOR], [m], [floor])
-AST_EXT_LIB_CHECK([CEIL], [m], [ceil])
-
AST_C_COMPILE_CHECK([GETIFADDRS], [struct ifaddrs *p; getifaddrs(&p)], [ifaddrs.h], , [getifaddrs() support])
GSM_INTERNAL="yes"