aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c117d2de4..b4f9ad07c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,6 +32,9 @@ case "${host_os}" in
LDFLAGS=-L/usr/local/lib
;;
+ darwin*)
+ AC_DEFINE([AST_POLL_COMPAT], 1, [Define to 1 if internal poll should be used.])
+ ;;
*)
ac_default_prefix=/usr
if test ${prefix} = '/usr' || test ${prefix} = 'NONE'; then
@@ -279,6 +282,10 @@ AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h libintl.h limits.h locale.h mal
AC_CHECK_HEADERS([winsock.h winsock2.h])
+AC_CHECK_HEADER([sys/poll.h],
+ [],
+ AC_DEFINE([AST_POLL_COMPAT], 1, [Define to 1 if internal poll should be used.]))
+
AC_SYS_LARGEFILE
# Checks for typedefs, structures, and compiler characteristics.