aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0d7c306e5..3715edb56 100644
--- a/configure.ac
+++ b/configure.ac
@@ -327,8 +327,18 @@ AC_CHECK_HEADER([sys/poll.h],
[HAS_POLL=1]
AC_DEFINE([HAVE_SYS_POLL_H], 1, [Define to 1 if your system has working sys/poll.h]),
)
+
+AC_ARG_ENABLE(internal-poll,
+ [ --enable-internal-poll Use Asterisk's poll implementation],
+ [case "${enableval}" in
+ y|ye|yes) HAS_POLL="";;
+ n|no) HAS_POLL="${HAS_POLL}" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-internal-poll) ;;
+ esac])
AC_SUBST(HAS_POLL)
+
+
# https support (in main/http.c) uses funopen on BSD systems,
# fopencookie on linux
AC_CHECK_FUNCS([funopen fopencookie])