aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f11a2cb89..29014011c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,12 @@ AC_REVISION($Revision$)
AC_USE_SYSTEM_EXTENSIONS # note- does not work on FreeBSD
+# preserve any CFLAGS or LDFLAGS that may be set
+CONFIG_CFLAGS="${CFLAGS}"
+CONFIG_LDFLAGS="${LDFLAGS}"
+AC_SUBST(CONFIG_CFLAGS)
+AC_SUBST(CONFIG_LDFLAGS)
+
case "${host_os}" in
freebsd*)
ac_default_prefix=/usr/local