aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 731197ff8..33ec19514 100644
--- a/configure.ac
+++ b/configure.ac
@@ -233,6 +233,7 @@ AST_EXT_LIB_SETUP([PGSQL], [PostgreSQL], [postgres])
AST_EXT_LIB_SETUP([POPT], [popt], [popt])
AST_EXT_LIB_SETUP([PORTAUDIO], [PortAudio], [portaudio])
AST_EXT_LIB_SETUP([PRI], [ISDN PRI], [pri])
+AST_EXT_LIB_SETUP([SPANDSP], [SPANDSP], [spandsp])
AST_EXT_LIB_SETUP([SS7], [ISDN SS7], [ss7])
AST_EXT_LIB_SETUP([PWLIB], [PWlib], [pwlib])
AST_EXT_LIB_SETUP([OPENH323], [OpenH323], [h323])
@@ -1290,6 +1291,12 @@ AST_EXT_LIB_CHECK([PORTAUDIO], [portaudio], [Pa_GetDeviceCount], [portaudio.h])
AST_EXT_LIB_CHECK([PRI], [pri], [pri_get_version], [libpri.h])
+AST_C_COMPILE_CHECK([SPANDSP], [
+ #if SPANDSP_RELEASE_DATE < 20080516
+ #error "spandsp 0.0.5 or greater is required"
+ #endif
+ ], [spandsp/version.h])
+
AST_EXT_LIB_CHECK([SS7], [ss7], [ss7_pollflags], [libss7.h])
if test "${USE_PWLIB}" != "no"; then