aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 79ebbe8ed..09368851f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1360,8 +1360,14 @@ fi
if test "${PBX_DAHDI}" = "1" || test "${USE_ZAPTEL}" = "no"; then
tonezone_dir="dahdi"
+ if test "x${DAHDI_DIR}" != "x"; then
+ tonezone_extra="${tonezone_extra} -I${DAHDI_DIR}/include"
+ fi
else
tonezone_dir="zaptel"
+ if test "x${ZAPTEL_DIR}" != "x"; then
+ tonezone_extra="${tonezone_extra} -I${ZAPTEL_DIR}/include"
+ fi
fi
AST_EXT_LIB_CHECK([TONEZONE], [tonezone], [tone_zone_find], [${tonezone_dir}/tonezone.h], [${tonezone_extra}])