aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrizzo <rizzo@f38db490-d61c-443f-a65b-d21fe96a405b>2007-06-28 19:29:34 +0000
committerrizzo <rizzo@f38db490-d61c-443f-a65b-d21fe96a405b>2007-06-28 19:29:34 +0000
commitb662f8ce92ab3b7e6bff9c60596f0a6138c133fd (patch)
tree71be3bfc999d2c398e1049196cff04ce60aebec6 /configure.ac
parent4e9c45097d73081ffc268cbced9569be0e3d093d (diff)
add a check for gethostbyname_r so we can
simplify the handling e.g. in utils.c Also add comments on a couple of features which are not working on FreeBSD. All the above has been already done in trunk so the merge must be blocked. Can someone please regenerate ./configure ? git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@72489 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index fd546ceee..770334f64 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,7 +22,7 @@ AC_COPYRIGHT("Asterisk")
AC_REVISION($Revision$)
AC_GNU_SOURCE
-AC_USE_SYSTEM_EXTENSIONS
+AC_USE_SYSTEM_EXTENSIONS # note- does not work on FreeBSD
case "${host_os}" in
freebsd*)
@@ -120,7 +120,7 @@ AC_PROG_CPP
AC_PROG_CXXCPP
# This macro is just copied into our local acinclude.m4 from libtool.m4 so that
# the developers regenerating the configure script don't have to install libtool.
-AST_PROG_LD
+AST_PROG_LD # note - does not work on freebsd
AC_PROG_AWK
AC_PROG_INSTALL
AC_PROG_LN_S
@@ -261,6 +261,9 @@ AC_FUNC_UTIME_NULL
AC_FUNC_VPRINTF
AC_CHECK_FUNCS([asprintf atexit bzero dup2 endpwent floor ftruncate getcwd gethostbyname gethostname getloadavg gettimeofday inet_ntoa isascii localtime_r memchr memmove memset mkdir munmap pow putenv re_comp regcomp rint select setenv socket sqrt strcasecmp strcasestr strchr strcspn strdup strerror strlcat strlcpy strncasecmp strndup strnlen strrchr strsep strspn strstr strtol strtoq unsetenv utime vasprintf])
+# some systems already have gethostbyname_r so we don't need to build ours in main/utils.c
+AC_CHECK_FUNCS([gethostbyname_r])
+
AC_MSG_CHECKING(for PTHREAD_RWLOCK_INITIALIZER)
AC_LINK_IFELSE(
AC_LANG_PROGRAM([#include <pthread.h>],