aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2008-11-04 15:07:54 +0000
committerkpfleming <kpfleming@f38db490-d61c-443f-a65b-d21fe96a405b>2008-11-04 15:07:54 +0000
commita73e71ff1e7e9605a6a356deb754150183d6b906 (patch)
tree548e478f6f70019b55bacc485591167d46591add /configure.ac
parentc7832dd1fdbd1c8d3b61cf6e3a3c0606c744bc9b (diff)
improve configure script to remember the previous value of each dependency in build_tools/menuselect-deps, so that (once it has been written) menuselect can use this information to warn the user when a previously met dependency is no longer met
along the way, change tags used in configure script, menuselect-deps and code for various dependencies to be consistently named git-svn-id: http://svn.digium.com/svn/asterisk/trunk@154151 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 14 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 43940aa4e..b3672b6c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,7 +82,7 @@ AC_SUBST(HOST_CPU)
AC_SUBST(HOST_VENDOR)
AC_SUBST(HOST_OS)
-WINARCH=0
+PBX_WINARCH=0
case "${host_os}" in
freebsd*)
@@ -99,11 +99,11 @@ case "${host_os}" in
;;
mingw32)
OSARCH=mingw32
- WINARCH=1
+ PBX_WINARCH=1
;;
cygwin)
OSARCH=cygwin
- WINARCH=1
+ PBX_WINARCH=1
;;
*)
OSARCH=${host_os}
@@ -111,7 +111,7 @@ case "${host_os}" in
esac
AC_SUBST(OSARCH)
-AC_SUBST(WINARCH)
+AC_SUBST(PBX_WINARCH)
# check for uname
AC_PATH_TOOL([UNAME], [uname], No)
@@ -1649,6 +1649,16 @@ fi
AC_CONFIG_FILES([build_tools/menuselect-deps makeopts channels/h323/Makefile])
AST_CHECK_MANDATORY
+if test -f build_tools/menuselect-deps; then
+ # extract old values of all PBX_ variables from menuselect-deps
+ # and preserve them so that menuselect can determine whether
+ # any previously-met dependencies are no longer met and warn
+ # the user appropriately
+ while IFS="=:" read var val old_val; do
+ eval "PBX_${var}=\${PBX_${var}}:${val}"
+ done < build_tools/menuselect-deps
+fi
+
AC_OUTPUT
if test "x${silent}" != "xyes" ; then