aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2010-01-21 15:32:48 +0000
committerseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2010-01-21 15:32:48 +0000
commita5eaf88780d54dfe6a1ca6fc79ac6597f7be7097 (patch)
tree71f9aab3bb7c0669df8248c2ffaef6c9caf9980e /configure.ac
parentaeb8dd0eb559ed71edb36024c1c2ba25bdaf0853 (diff)
Merged revisions 241938 via svnmerge from
https://origsvn.digium.com/svn/asterisk/trunk ................ r241938 | seanbright | 2010-01-21 10:27:42 -0500 (Thu, 21 Jan 2010) | 12 lines Merged revisions 241932 via svnmerge from https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r241932 | seanbright | 2010-01-21 10:25:46 -0500 (Thu, 21 Jan 2010) | 5 lines Fix configure check for PTHREAD_ONCE_INIT when manually adding -Wall to CFLAGS. (closes issue #16666) Reported by: romain_proformatique ........ ................ git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.6.2@241941 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e60528734..d785c6df9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -503,8 +503,9 @@ saved_CFLAGS="${CFLAGS}"
CFLAGS="${CFLAGS} -Werror -Wmissing-braces"
AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM(
- [#include <pthread.h>],
- [pthread_once_t once = PTHREAD_ONCE_INIT;])
+ [#include <pthread.h>
+ void empty(){}],
+ [pthread_once_t once = PTHREAD_ONCE_INIT; pthread_once(&once, empty);])
],[
AC_MSG_RESULT(no)
ac_cv_pthread_once_needsbraces="no"