aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-02-17 01:11:32 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-02-17 01:11:32 +0000
commit747d67efc874c9aeea7301ae1b09735bc5ae5303 (patch)
tree5c95ebb73f1ae1aff7f702088547f256388d91a0 /configure.ac
parent1dcb8c3a4b308e99e79c1629941ba6985fc2fd99 (diff)
Merged revisions 55052 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r55052 | russell | 2007-02-16 18:40:34 -0600 (Fri, 16 Feb 2007) | 3 lines If the pg_config application is found, but there is probably executing it, then consider postgres unavailable. (issue #8637) ........ git-svn-id: http://svn.digium.com/svn/asterisk/trunk@55077 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 24 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index e6478ec15..d0ddea526 100644
--- a/configure.ac
+++ b/configure.ac
@@ -693,14 +693,30 @@ fi
if test "${PG_CONFIG}" != No; then
PGSQL_libdir=`${PG_CONFIG} --libdir`
PGSQL_includedir=`${PG_CONFIG} --includedir`
-
- AC_CHECK_LIB([pq], [PQexec], AC_DEFINE_UNQUOTED([HAVE_PGSQL], 1,
- [Define to indicate the PostgreSQL library]), [], -L${PGSQL_libdir} -lz)
-
- if test "${ac_cv_lib_pq_PQexec}" = "yes"; then
- PGSQL_LIB="-L${PGSQL_libdir} -lpq -lz"
- PGSQL_INCLUDE="-I${PGSQL_includedir}"
- PBX_PGSQL=1
+ if test "x$?" != "x0" ; then
+ if test -n "${PGSQL_MANDATORY}" ; then
+ AC_MSG_NOTICE([***])
+ AC_MSG_NOTICE([*** The PostgreSQL installation on this system appears to be broken.])
+ AC_MSG_NOTICE([*** Either correct the installation, or run configure])
+ AC_MSG_NOTICE([*** including --without-postgres])
+ exit 1
+ fi
+ else
+ AC_CHECK_LIB([pq], [PQexec], AC_DEFINE_UNQUOTED([HAVE_PGSQL], 1,
+ [Define to indicate the PostgreSQL library]), [], -L${PGSQL_libdir} -lz)
+
+ if test "${ac_cv_lib_pq_PQexec}" = "yes"; then
+ PGSQL_LIB="-L${PGSQL_libdir} -lpq -lz"
+ PGSQL_INCLUDE="-I${PGSQL_includedir}"
+ PBX_PGSQL=1
+ elif test -n "${PGSQL_MANDATORY}";
+ then
+ AC_MSG_NOTICE([***])
+ AC_MSG_NOTICE([*** The PostgreSQL installation on this system appears to be broken.])
+ AC_MSG_NOTICE([*** Either correct the installation, or run configure])
+ AC_MSG_NOTICE([*** including --without-postgres])
+ exit 1
+ fi
fi
fi