aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-03-13 21:22:33 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-03-13 21:22:33 +0000
commit607988f17b6ab703402b22502b751ebe9fa1ec3b (patch)
tree09826367dd718544b289f1484e5bb40393f8c414 /configure.ac
parente6cf30c5ae0a9157f66d4e42e95c796a1741ea9d (diff)
Merge changes from team/russell/sqlite:
* Add new module, cdr_sqlite3_custom which allows logging custom CDRs into a SQLite3 database. (issue #7149, alerios) * Add new module, res_config_sqlite, which adds realtime database configuration support for SQLite version 2. I decided that this was ok since we didn't have any realtime support for version 3. If someone ports this to version 3, then version 2 support can be removed or marked deprecated. (issue #7790, rbarun_proformatique) * Mark cdr_sqlite as deprecated in favor of cdr_sqlite3_custom. Also, note that there were other modules on the bug tracker that did not make the cut because they provided some duplicated functionality. Those are: * cdr_sqlite3 (issue #6754, moy) * cdr_sqlite3 (issue #8694, bsd) git-svn-id: http://svn.digium.com/svn/asterisk/trunk@58866 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2039153c0..0f6acbf37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -210,6 +210,7 @@ AST_EXT_LIB_SETUP([QT], [Qt], [qt])
AST_EXT_LIB_SETUP([RADIUS], [Radius Client], [radius])
AST_EXT_LIB_SETUP([SPEEX], [Speex], [speex])
AST_EXT_LIB_SETUP([SQLITE], [SQLite], [sqlite])
+AST_EXT_LIB_SETUP([SQLITE3], [SQLite], [sqlite3])
AST_EXT_LIB_SETUP([SUPPSERV], [mISDN Supplemental Services], [suppserv])
AST_EXT_LIB_SETUP([OPENSSL], [OpenSSL], [ssl])
AST_EXT_LIB_SETUP([FREETDS], [FreeTDS], [tds])
@@ -832,6 +833,8 @@ AST_EXT_LIB_CHECK([SPEEX], [speex], [speex_encode], [speex/speex.h], [-lm])
AST_EXT_LIB_CHECK([SQLITE], [sqlite], [sqlite_exec], [sqlite.h])
+AST_EXT_LIB_CHECK([SQLITE3], [sqlite3], [sqlite3_open], [sqlite3.h])
+
AST_EXT_LIB_CHECK([OPENSSL], [ssl], [ssl2_connect], [openssl/ssl.h], [-lcrypto])
AST_EXT_LIB_CHECK([FREETDS], [tds], [tds_version], [tds.h])