aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorjpeeler <jpeeler@f38db490-d61c-443f-a65b-d21fe96a405b>2009-04-14 15:54:16 +0000
committerjpeeler <jpeeler@f38db490-d61c-443f-a65b-d21fe96a405b>2009-04-14 15:54:16 +0000
commit24045a66eaa6e12dccbb0a8a219e4ced81bb54a0 (patch)
treee97a2215b2d25fa450635082b3eed88a45c2f9b0 /configure.ac
parent9091ffc287226ca83b6821b13b351abf2d14eb7e (diff)
Add service maintenance message support
This is the companion commit to libpri r732. Service messages are now supported for switch types 4ess/5ess. A new option service_message_support has been added to chan_dahdi.conf and is noted in the sample config file. The service message support is turned off by default. The current implementation relies on AstDB to keep track of channel state, which allows the statuses to be preserved across Asterisk restarts. Below is a description of the storage format. The state and reason for the service state are in the form <state>:<reason>, where: <state> ::= { 'O' } // 'O' – Out Of Service <reason> ::= { '0' | '1' | '2' | '3' }, where: '0' – No reason (backwards compatibility) '1' – NEAR END '2' – FAR END '3' – both NEAR and FAR END The new CLI commands to handle channel service state are: pri service disable channel <chan> pri service enable channel <chan> Many people contributed to the development of this functionality. Because I entered at the very end I do not know the exact history. Special thanks to all who moved the bug forward one way or another: cmaj, PCadach, markster, mattf, drmac, MikeJ, serge-v, murf, kanelbullar, Seb7, tilghman, lmadsen, and especially dhubbard (he answered lots of my questions and did a large portion of the work) (closes issue #3450) Reported by: cmaj git-svn-id: http://svn.digium.com/svn/asterisk/trunk@188342 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ac129accc..00220d238 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1404,6 +1404,8 @@ AST_EXT_LIB_CHECK([PRI_PROG_W_CAUSE], [pri], [pri_progress_with_cause], [libpri.
AST_EXT_LIB_CHECK([PRI_INBANDDISCONNECT], [pri], [pri_set_inbanddisconnect], [libpri.h])
+AST_EXT_LIB_CHECK([PRI_SERVICE_MESSAGES], [pri], [pri_maintenance_service], [libpri.h])
+
AST_EXT_LIB_CHECK([RESAMPLE], [resample], [resample_open], [libresample.h], [-lm])
AST_C_COMPILE_CHECK([SPANDSP], [