aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authortilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2010-01-25 20:15:45 +0000
committertilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2010-01-25 20:15:45 +0000
commit0e0abf9d1c97e272b9f72d6b96eb69eb62eba1b4 (patch)
treef118368712e9d2ee5f8b0649e2019231d2f42042 /configure.ac
parent6b4b10cc88b2d459ae002d08922666f07124963d (diff)
Restore FreeBSD to able-to-compile-ish-mode
git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@242852 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aa1ddb0be..4a87657c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -162,6 +162,39 @@ else
fi
AC_SUBST(DOWNLOAD)
+AC_CACHE_CHECK([for bison that supports parse-param], [ac_cv_path_BISON2], [
+ if test "x$BISON" != "x:" ; then
+ # Create a temporary directory $tmp in $TMPDIR (default /tmp).
+ # Use mktemp if possible; otherwise fall back on mkdir,
+ # with $RANDOM to make collisions less likely.
+ : ${TMPDIR=/tmp}
+ {
+ tmp=`
+ (umask 077 && mktemp -d "$TMPDIR/fooXXXXXX") 2>/dev/null
+ ` &&
+ test -n "$tmp" && test -d "$tmp"
+ } || {
+ tmp=$TMPDIR/foo$$-$RANDOM
+ (umask 077 && mkdir "$tmp")
+ } || exit $?
+ cat >$tmp/test.y <<__EOL__
+%parse-param {struct parse_io *parseio}
+%%
+file : { \$\$ = parseio->pval = 1; }
+ ;
+%%
+__EOL__
+ ${BISON} -o ${tmp}/test.tab.c ${tmp}/test.y >/dev/null 2>&1
+ if test -e "${tmp}/test.tab.c"; then
+ ac_cv_path_BISON2=${BISON}
+ fi
+ rm -rf ${tmp}
+ fi
+ ])
+if test "x${ac_cv_path_BISON2}" = "x" ; then
+ BISON=:
+fi
+
AC_CHECK_TOOL([SOXMIX], [soxmix], [:])
if test "${SOXMIX}" != ":" ; then
AC_DEFINE([HAVE_SOXMIX], 1, [Define to 1 if your system has soxmix application.])