aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2008-01-09 22:51:15 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2008-01-09 22:51:15 +0000
commit989737c4c926dd9bb67f4d3468c95fceddd73293 (patch)
tree57fe2f2716e0e521b62d49ee0fff87700c3f9b49 /configure.ac
parenta26a31b0b2092f6e682a95c754a3a454430ff476 (diff)
re-add check for gtk1, which is used for pbx_gtkconsole
(related to issue #11706) git-svn-id: http://svn.digium.com/svn/asterisk/trunk@97643 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a060636e4..286f19d70 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1225,8 +1225,17 @@ AC_CHECK_HEADER([linux/videodev.h],
AST_EXT_LIB_CHECK([X11], [X11], [XOpenDisplay], [X11/Xlib.h],,, [standard_path])
AST_EXT_LIB_CHECK([X11], [X11], [XOpenDisplay], [X11/Xlib.h],, [-I/usr/X11R6/include], [X11R6])
-# we don't use gtk right now...
-AST_EXT_TOOL_CHECK([GTK], [gtk])
+PBX_GTK=0
+AC_CHECK_TOOL(GTKCONFIG, gtk-config, No)
+if test ! "x${GTKCONFIG}" = xNo; then
+ GTK_INCLUDE=$(${GTKCONFIG} --cflags gthread)
+ GTK_LIB=$(${GTKCONFIG} --libs gthread)
+ PBX_GTK=1
+ AC_DEFINE([HAVE_GTK], 1, [Define if your system has the GTK libraries.])
+fi
+AC_SUBST(PBX_GTK)
+AC_SUBST(GTK_INCLUDE)
+AC_SUBST(GTK_LIB)
PBX_GTK2=0
AC_CHECK_TOOL(PKGCONFIG, pkg-config, No)