aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authormvanbaak <mvanbaak@f38db490-d61c-443f-a65b-d21fe96a405b>2008-10-07 18:53:34 +0000
committermvanbaak <mvanbaak@f38db490-d61c-443f-a65b-d21fe96a405b>2008-10-07 18:53:34 +0000
commitaca7b817044a3d7a38fb64523786a107180bdf73 (patch)
tree800d9c308b6162f2618f7630cc625769df47523e /configure.ac
parent8c0e9e8e608545eab82f6699051100158e69f00c (diff)
Make sure the configs on OpenBSD are in /etc/asterisk by default
(closes issue #13641) Reported by: jtodd git-svn-id: http://svn.digium.com/svn/asterisk/trunk@147306 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ac0588f8e..a4ff93cb3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,12 +27,24 @@ AC_GNU_SOURCE
AC_USE_SYSTEM_EXTENSIONS # note- does not work on FreeBSD
case "${host_os}" in
- freebsd*|openbsd*)
+ freebsd*)
ac_default_prefix=/usr/local
CPPFLAGS=-I/usr/local/include
LDFLAGS=-L/usr/local/lib
;;
-
+ openbsd*)
+ ac_default_prefix=/usr/local
+ if test ${prefix} = '/usr/local' || test ${prefix} = 'NONE'; then
+ if test ${sysconfdir} = '${prefix}/etc'; then
+ sysconfdir=/etc
+ fi
+ if test ${mandir} = '${prefix}/man'; then
+ mandir=/usr/share/man
+ fi
+ fi
+ CPPFLAGS=-I/usr/local/include
+ LDFLAGS=-L/usr/local/lib
+ ;;
*)
ac_default_prefix=/usr
if test ${prefix} = '/usr' || test ${prefix} = 'NONE'; then