aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authormmichelson <mmichelson@f38db490-d61c-443f-a65b-d21fe96a405b>2008-10-16 21:23:38 +0000
committermmichelson <mmichelson@f38db490-d61c-443f-a65b-d21fe96a405b>2008-10-16 21:23:38 +0000
commit8161f11e1c4513afd9d4fc4a586bd81312cb9c07 (patch)
tree11af4c8e1adc6725b97a8e49a5fd46a5308bd16d /configure.ac
parente4ca5ed34308510f52641ef5aaaeef5654908e31 (diff)
Change configure script to search for openais in
both /usr/lib and /usr/lib64 since some distros place 64-bit libraries only in the /usr/lib64 directory. (closes issue #13721) Reported by: jcollie Patches: 0007-Look-in-64bit-dirs-for-openais.patch uploaded by jcollie (license 412) git-svn-id: http://svn.digium.com/svn/asterisk/trunk@150210 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 30bcd9db2..426db49d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1410,7 +1410,7 @@ PBX_AIS=0
# OpenAIS installs its libraries into /usr/lib/openais by default, so check there
-AST_EXT_LIB_CHECK([OPENAIS], [SaClm], [saClmInitialize], [openais/saClm.h], [-L/usr/lib/openais])
+AST_EXT_LIB_CHECK([OPENAIS], [SaClm], [saClmInitialize], [openais/saClm.h], [-L/usr/lib/openais -L/usr/lib64/openais])
if test "${PBX_OPENAIS}" = 1; then
PBX_AIS=1
@@ -1419,7 +1419,7 @@ if test "${PBX_OPENAIS}" = 1; then
AIS_LIB="-lSaEvt ${OPENAIS_LIB}"
else
AIS_INCLUDE="-I/usr/include/openais"
- AIS_LIB="-lSaClm -lSaEvt -L/usr/lib/openais"
+ AIS_LIB="-lSaClm -lSaEvt -L/usr/lib/openais -L/usr/lib64/openais"
fi
fi