aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorlmadsen <lmadsen@f38db490-d61c-443f-a65b-d21fe96a405b>2010-04-21 19:30:18 +0000
committerlmadsen <lmadsen@f38db490-d61c-443f-a65b-d21fe96a405b>2010-04-21 19:30:18 +0000
commit3bc456b8a0769b1a5451730cc43c0c23f2019fd4 (patch)
tree502b0118d7354162c0e85404c18e26f9dfe75e84 /configure.ac
parentdc620b92dc44fb8cf1dfbdd985e9e3e8d3739e71 (diff)
Merged revisions 258351 via svnmerge from
https://origsvn.digium.com/svn/asterisk/trunk ........ r258351 | lmadsen | 2010-04-21 14:18:35 -0500 (Wed, 21 Apr 2010) | 20 lines Add ability to generate ASCII documentation from the TeX files. These changes add the ability to run 'make asterisk.txt' just like the existing 'make asterisk.pdf' commands to generate a text document from the TeX files we have in the doc/tex/ directory. I've also updated a few of the .tex files because they weren't properly escaping certain characters so they would show up as Unicode characters (like [U+021C]). Made changes to the configure scripts so it would detect the catdvi program which is required to convert the .dvi file generated by latex. I've also added a few lines to the build_tools/prep_tarball script so that the text documentation gets generated and added to future tarballs of Asterisk releases. (closes issue #17220) Reported by: lmadsen Patches: asterisk.txt.patch uploaded by lmadsen (license 10) asterisk.txt.patch-v4 uploaded by pabelanger (license 224) Tested by: lmadsen, pabelanger ........ git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.6.2@258384 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e3a295536..922e7c441 100644
--- a/configure.ac
+++ b/configure.ac
@@ -197,6 +197,7 @@ AC_PATH_PROG([DOT], [dot], :)
AC_PATH_PROG([WGET], [wget], :)
AC_PATH_PROG([CURL], [curl], :)
AC_PATH_PROG([RUBBER], [rubber], :)
+AC_PATH_PROG([CATDVI], [catdvi], :)
AC_PATH_PROG([KPATHSEA], [kpsewhich], :)
AC_PATH_PROG([XMLSTARLET], [xmlstarlet], :)
if test "${WGET}" != ":" ; then