aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2010-01-21 15:25:46 +0000
committerseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2010-01-21 15:25:46 +0000
commit16e40a938067b9948836cda8dc72775fd5616182 (patch)
treed97c44623c98ae19c01a8c6ed3d10688adcc3247 /configure.ac
parent6458002f09e42034f0fa2e8b88f44063434e4881 (diff)
Fix configure check for PTHREAD_ONCE_INIT when manually adding -Wall to CFLAGS.
(closes issue #16666) Reported by: romain_proformatique git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@241932 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index efeedb56d..a4f2dc317 100644
--- a/configure.ac
+++ b/configure.ac
@@ -357,8 +357,9 @@ saved_CFLAGS="${CFLAGS}"
CFLAGS="${CFLAGS} -Werror -Wmissing-braces"
AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM(
- [#include <pthread.h>],
- [pthread_once_t once = PTHREAD_ONCE_INIT;])
+ [#include <pthread.h>
+ void empty(){}],
+ [pthread_once_t once = PTHREAD_ONCE_INIT; pthread_once(&once, empty);])
],[
AC_MSG_RESULT(no)
ac_cv_pthread_once_needsbraces="no"