aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorqwell <qwell@f38db490-d61c-443f-a65b-d21fe96a405b>2009-03-11 22:18:42 +0000
committerqwell <qwell@f38db490-d61c-443f-a65b-d21fe96a405b>2009-03-11 22:18:42 +0000
commit154403558bdf20b1bff511b54a7cb37d1aebfcdf (patch)
treeb5d1a4acda9143dc8e0894f41255e34ee75eae9e /configure.ac
parent5e7e50f861dcc72b4be6c4754341c6697c867098 (diff)
Allow prefix to set localstatedir (when used and different from the default).
This is similar to the /etc change that was made for the non-FreeBSD case. git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.4@181436 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f00edc471..8282f9f5f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,8 +38,10 @@ case "${host_os}" in
;;
esac
-if test ${localstatedir} = '${prefix}/var'; then
- localstatedir=/var
+if test ${prefix} = ${ac_default_prefix} || test ${prefix} = 'NONE'; then
+ if test ${localstatedir} = '${prefix}/var'; then
+ localstatedir=/var
+ fi
fi
BUILD_PLATFORM=${build}