aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authortilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2010-08-31 20:22:10 +0000
committertilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2010-08-31 20:22:10 +0000
commit62e5d8890e77713b6724fd877378269ee45137cf (patch)
treedb0238f4e0a56c1b63caee10abdebfd398d39623 /configure.ac
parent815b5b09da5e555add7bba3d8fca588e7611248a (diff)
Merged revisions 284399 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.6.2 ................ r284399 | tilghman | 2010-08-31 15:18:32 -0500 (Tue, 31 Aug 2010) | 14 lines Merged revisions 284393 via svnmerge from https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r284393 | tilghman | 2010-08-31 15:13:21 -0500 (Tue, 31 Aug 2010) | 7 lines Don't send a devstate change on poke_noanswer if the state did not change. (closes issue #17741) Reported by: schmidts Patches: chan_sip.c.patch uploaded by schmidts (license 1077) ........ ................ git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.8@284415 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 32 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dfc45a5e8..62e7895c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1807,6 +1807,38 @@ fi
AST_EXT_LIB_CHECK([SRTP], [srtp], [srtp_init], [srtp/srtp.h])
+if test "$PBX_SRTP" = "1";
+then
+ saved_libs="${LIBS}"
+ saved_ldflags="${LDFLAGS}"
+ LIBS="${LIBS} -lsrtp"
+ LDFLAGS="${LDFLAGS} -shared -fPIC"
+ AC_MSG_CHECKING(for the ability of -lsrtp to be linked in a shared object)
+ AC_LINK_IFELSE(
+ [
+ AC_LANG_PROGRAM(
+ [#include <srtp/srtp.h>],
+ [srtp_init();]
+ )
+ ],
+ [ AC_MSG_RESULT(yes) ],
+ [
+ AC_MSG_RESULT(no)
+ AC_MSG_NOTICE(***)
+ AC_MSG_NOTICE(*** libsrtp could not be linked as a shared object)
+ AC_MSG_NOTICE(*** try compiling libsrtp manually and configuring with)
+ AC_MSG_NOTICE(*** ./configure CFLAGS=-fPIC --prefix=/usr)
+ AC_MSG_NOTICE(*** replacing /usr with the prefix of your choice)
+ AC_MSG_NOTICE(***)
+ AC_MSG_NOTICE(*** If you do not need SRTP support re-run configure)
+ AC_MSG_NOTICE(*** with the --without-srtp option.)
+ exit 1
+ ]
+ )
+ LIBS="${saved_libs}"
+ LDFLAGS="${saved_ldflags}"
+fi
+
AST_EXT_TOOL_CHECK([GMIME], [gmime-config], [], [], [#include <gmime/gmime.h>], [gboolean q = g_mime_check_version(0,0,0);])
AST_EXT_LIB_CHECK([HOARD], [hoard], [malloc], [])