aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2010-07-27 21:16:05 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2010-07-27 21:16:05 +0000
commitbebdb0fda152a29d8e336408d2eee31d06bce0d7 (patch)
tree2f45bd7a37f60dff2947af5cbf3447c4e02e73c1 /configure.ac
parent371b257de0045a90119b5775a3c716b6bbab9f82 (diff)
Add --enable-coverage option to configure script.
This option enables the proper compiler flags for tracking code coverage, which is useful along side automated testing. git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.8@279953 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b0adfd761..dfc45a5e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -288,6 +288,17 @@ AC_ARG_ENABLE([dev-mode],
AC_SUBST(NOISY_BUILD)
AC_SUBST(AST_DEVMODE)
+AST_CODE_COVERAGE=no
+AC_ARG_ENABLE([coverage],
+ [AS_HELP_STRING([--enable-coverage],
+ [Turn on code coverage tracking (for gcov)])],
+ [case "${enableval}" in
+ y|ye|yes) AST_CODE_COVERAGE=yes ;;
+ n|no) AST_CODE_COVERAGE=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-coverage) ;;
+ esac])
+AC_SUBST(AST_CODE_COVERAGE)
+
# AST_EXT_LIB_SETUP is used to tell configure to handle variables for
# various packages.
# $1 is the prefix for the variables in makeopts and autoconfig.h