aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2007-08-06 14:20:04 +0000
committerfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2007-08-06 14:20:04 +0000
commite1e7b35fee547a3134a333bc9d80a267f9b9d5af (patch)
treecad580c4f60e5a817ed873982071831ab058d424 /configure.ac
parentbd270a15e858829a60f69c6acd7035e1ad98e1bc (diff)
Merged revisions 78166 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r78166 | file | 2007-08-06 11:18:20 -0300 (Mon, 06 Aug 2007) | 4 lines (closes issue #10383) Reported by: rizzo Include stdlib.h so NULL gets defined for gethostbyname_r checks. ........ git-svn-id: http://svn.digium.com/svn/asterisk/trunk@78167 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cb6bc26b6..c4093ff56 100644
--- a/configure.ac
+++ b/configure.ac
@@ -288,7 +288,8 @@ AC_SEARCH_LIBS(gethostbyname_r, [socket nsl])
AC_MSG_CHECKING(for gethostbyname_r with 6 arguments)
AC_LINK_IFELSE(
- AC_LANG_PROGRAM([#include <netdb.h>],
+ AC_LANG_PROGRAM([#include <stdlib.h>
+ #include <netdb.h>],
[struct hostent *he = gethostbyname_r((const char *)NULL, (struct hostent *)NULL, (char *)NULL, (int)0, (struct hostent **)NULL, (int *)NULL);]),
AC_MSG_RESULT(yes)
AC_DEFINE([HAVE_GETHOSTBYNAME_R_6], 1, [Define to 1 if your system has gethostbyname_r with 6 arguments.]),
@@ -297,7 +298,8 @@ AC_LINK_IFELSE(
AC_MSG_CHECKING(for gethostbyname_r with 5 arguments)
AC_LINK_IFELSE(
- AC_LANG_PROGRAM([#include <netdb.h>],
+ AC_LANG_PROGRAM([#include <stdlib.h>
+ #include <netdb.h>],
[struct hostent *he = gethostbyname_r((const char *)NULL, (struct hostent *)NULL, (char *)NULL, (int)0, (int *)NULL);]),
AC_MSG_RESULT(yes)
AC_DEFINE([HAVE_GETHOSTBYNAME_R_5], 1, [Define to 1 if your system has gethostbyname_r with 5 arguments.]),