aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2009-07-30 23:37:31 +0000
committerseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2009-07-30 23:37:31 +0000
commitcc77174d980650701aa0027e27554aac85e5e55e (patch)
tree7e42188206184b3c23c8feedd189052fccff1c57 /configure.ac
parent81622bec749bb267459242602e435c5d62f3949c (diff)
Allow passing 'noisy' to configure's --enable-dev-mode argument to turn on verbose builds.
(closes issue #15607) Reported by: mvanbaak Patches: 20090730_issue15607.patch uploaded by seanbright (license 71) Tested by: seanbright git-svn-id: http://svn.digium.com/svn/asterisk/trunk@209623 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 38c43ca27..4e2d0decc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -214,8 +214,13 @@ AC_ARG_ENABLE([dev-mode],
[case "${enableval}" in
y|ye|yes) AST_DEVMODE=yes ;;
n|no) AST_DEVMODE=no ;;
+ noisy)
+ AST_DEVMODE=yes
+ NOISY_BUILD=yes
+ ;;
*) AC_MSG_ERROR(bad value ${enableval} for --enable-dev-mode) ;;
esac])
+AC_SUBST(NOISY_BUILD)
AC_SUBST(AST_DEVMODE)
# AST_EXT_LIB_SETUP is used to tell configure to handle variables for