aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authortilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2010-05-08 02:40:01 +0000
committertilghman <tilghman@f38db490-d61c-443f-a65b-d21fe96a405b>2010-05-08 02:40:01 +0000
commitc5c5d512610a1d6290e3248d8f5b6a9684e9158c (patch)
tree290b4005f4cba562e838e3330281ddae30df1234 /configure.ac
parentb8e93fda2bb16ecc1571a9f631932336a9b0a4a5 (diff)
Use CPPFLAGS to pass PTHREAD_CFLAGS for vpb only
git-svn-id: http://svn.digium.com/svn/asterisk/trunk@262048 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index b7647cabd..d8da16e14 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1730,7 +1730,6 @@ AC_LANG_PUSH(C++)
if test "${USE_VPB}" != "no"; then
AC_MSG_CHECKING(for vpb_open in -lvpb)
saved_libs="${LIBS}"
- saved_cflags="${CFLAGS}"
saved_cppflags="${CPPFLAGS}"
if test "x${VPB_DIR}" != "x"; then
if test -d ${VPB_DIR}/lib; then
@@ -1742,7 +1741,7 @@ if test "${USE_VPB}" != "no"; then
CPPFLAGS="${CPPFLAGS} -I${VPB_DIR}/include"
fi
LIBS="${PTHREAD_LIBS} ${LIBS} -lvpb"
- CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
+ CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS}"
AC_LINK_IFELSE(
[
AC_LANG_PROGRAM(
@@ -1756,7 +1755,6 @@ if test "${USE_VPB}" != "no"; then
ac_cv_lib_vpb_vpb_open="no"
]
)
- CFLAGS="${saved_cflags}"
LIBS="${saved_libs}"
CPPFLAGS="${saved_cppflags}"
if test "${ac_cv_lib_vpb_vpb_open}" = "yes"; then