aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-06-18 16:35:51 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-06-18 16:35:51 +0000
commit36a2e6ea7e7f77dcdb5dce866f5e2ee60181b631 (patch)
treeca7524e836d40e4587b0cbfae4050fca1339d57f /configure.ac
parent8f690f929aafac06c5f86eaca97e588b49d10256 (diff)
Merged revisions 69702 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r69702 | russell | 2007-06-18 11:35:02 -0500 (Mon, 18 Jun 2007) | 6 lines To prevent 92138749238754 more reports of "I have unixodbc installed, but still can't build *_odbc.so!", check for ltdl directly, instead of just listing it as another library to include in the unixodbc check in the configure script. This also makes ltdl show up as a dependency in menuselect so people know what to go install. (related to issue #9989, patch by me) ........ git-svn-id: http://svn.digium.com/svn/asterisk/trunk@69703 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9d0a628c5..50945031a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -193,6 +193,7 @@ AST_EXT_LIB_SETUP([IKSEMEL], [Iksemel Jabber Library], [iksemel])
AST_EXT_LIB_SETUP([IMAP_TK], [UW IMAP Toolkit], [imap])
AST_EXT_LIB_SETUP([ISDNNET], [ISDN4Linux Library], [isdnnet])
AST_EXT_LIB_SETUP([KDE], [KDE], [kde])
+AST_EXT_LIB_SETUP([LTDL], [libtool], [ltdl])
AST_EXT_LIB_SETUP([MISDN], [mISDN User Library], [misdn])
AST_EXT_LIB_SETUP([NBS], [Network Broadcast Sound], [nbs])
AST_EXT_LIB_SETUP([NCURSES], [ncurses], [ncurses])
@@ -580,6 +581,9 @@ if test "${USE_IMAP_TK}" != "no"; then
fi
fi
+# Needed by unixodbc
+AST_EXT_LIB_CHECK([LTDL], [ltdl], [lt_dlinit], [ltdl.h], [])
+
AC_LANG_PUSH(C++)
if test "${USE_KDE}" != "no"; then
@@ -671,7 +675,7 @@ fi
AST_EXT_LIB_CHECK([NEWT], [newt], [newtBell], [newt.h])
-AST_EXT_LIB_CHECK([UNIXODBC], [odbc], [SQLConnect], [sql.h], [-lltdl])
+AST_EXT_LIB_CHECK([UNIXODBC], [odbc], [SQLConnect], [sql.h], [])
AST_EXT_LIB_CHECK([OGG], [ogg], [ogg_sync_init], [])