aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-06-29 21:24:40 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2007-06-29 21:24:40 +0000
commit14d66dd72cdeb657bab548319cdc5ecf800653e6 (patch)
tree45bd741392c5eea6f6512dae3be9ee1421a7b2b2 /configure.ac
parent132c6654622343091e31abe1c31775963bc7bc51 (diff)
Fix my recent change for sending large files via the http server. This code
*must* write the file to the FILE *, and not the raw fd. Otherwise, it breaks TLS support. Thanks to rizzo for catching this! git-svn-id: http://svn.digium.com/svn/asterisk/trunk@72738 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 0 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 9e8279d07..4c4a48c7a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -364,23 +364,6 @@ AC_CHECK_HEADER([libkern/OSAtomic.h],
AC_CHECK_SIZEOF(int)
-AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM(
- [#include <stdlib.h>
- #include <sys/sendfile.h>],
- [sendfile(1, 0, NULL, 1);])
- ],[
- AC_MSG_RESULT(yes)
- have_sendfile=yes
- ],[
- AC_MSG_RESULT(no)
- have_sendfile=no
- ]
-)
-if test "${have_sendfile}" = "yes"; then
- AC_DEFINE([HAVE_SENDFILE], 1, [Define if your system has the sendfile syscall.])
-fi
-
# do the package library checks now
AST_EXT_LIB_CHECK([ALSA], [asound], [snd_spcm_init], [alsa/asoundlib.h], [-lm -ldl])