aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2008-06-02 15:58:41 +0000
committerrussell <russell@f38db490-d61c-443f-a65b-d21fe96a405b>2008-06-02 15:58:41 +0000
commit904b8ccfc7266640f70a01f054f702b43c6f8929 (patch)
treecce05b78eb3dea1ab7a36ddfef075ac3455a3030 /configure.ac
parent899a6860452b357a13d4b12fa8d72f21542696f5 (diff)
Merged revisions 119799 via svnmerge from
https://origsvn.digium.com/svn/asterisk/trunk ........ r119799 | russell | 2008-06-02 10:57:43 -0500 (Mon, 02 Jun 2008) | 4 lines After determining that the version of spandsp installed is an acceptable version, do a build and link test to ensure that the library is usable, and that libtiff is also available ........ git-svn-id: http://svn.digium.com/svn/asterisk/branches/1.6.0@119800 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3720e7921..5bf3b6b35 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1296,6 +1296,13 @@ AST_C_COMPILE_CHECK([SPANDSP], [
#endif
], [spandsp/version.h])
+if test "x${PBX_SPANDSP}" = "x1" ; then
+ # We found the correct version in the header, now let's make sure it links
+ # properly, and that libtiff is available
+ PBX_SPANDSP=0
+ AST_EXT_LIB_CHECK([SPANDSP], [spandsp], [span_set_message_handler], [spandsp.h], [-ltiff])
+fi
+
AST_EXT_LIB_CHECK([SS7], [ss7], [ss7_pollflags], [libss7.h])
if test "${USE_PWLIB}" != "no"; then