aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authormmichelson <mmichelson@f38db490-d61c-443f-a65b-d21fe96a405b>2008-01-28 21:07:18 +0000
committermmichelson <mmichelson@f38db490-d61c-443f-a65b-d21fe96a405b>2008-01-28 21:07:18 +0000
commite9f4b79cb8a0036acc5bb3ca1e9186543f0197cb (patch)
tree722e398dfbf20defced4c8dc4ebc1fd1cf42b653 /configure.ac
parent4e76b6d7b5a1545a54d829bf408554dd678bd3df (diff)
Re-inserting chan_vpb into trunk.
git-svn-id: http://svn.digium.com/svn/asterisk/trunk@100678 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac45
1 files changed, 45 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7f329c402..b93673763 100644
--- a/configure.ac
+++ b/configure.ac
@@ -248,6 +248,7 @@ AST_EXT_LIB_SETUP([TINFO], [Term Info], [tinfo])
AST_EXT_LIB_SETUP([TONEZONE], [tonezone], [tonezone])
AST_EXT_LIB_SETUP([USB], [usb], [usb])
AST_EXT_LIB_SETUP([VORBIS], [Vorbis], [vorbis])
+AST_EXT_LIB_SETUP([VPB], [Voicetronix API], [vpb])
AST_EXT_LIB_SETUP([X11], [X11 support], [x11])
AST_EXT_LIB_SETUP([ZLIB], [zlib], [z])
AST_EXT_LIB_SETUP([ZAPTEL], [Zaptel], [zaptel])
@@ -1004,6 +1005,50 @@ AST_EXT_LIB_CHECK([USB], [usb], [usb_init], [usb.h], [])
AST_EXT_LIB_CHECK([VORBIS], [vorbis], [vorbis_info_init], [vorbis/codec.h], [-lm -lvorbisenc])
+AC_LANG_PUSH(C++)
+
+if test "${USE_VPB}" != "no"; then
+ AC_MSG_CHECKING(for vpb_open in -lvpb)
+ saved_libs="${LIBS}"
+ saved_cppflags="${CPPFLAGS}"
+ if test "x${VPB_DIR}" != "x"; then
+ if test -d ${VPB_DIR}/lib; then
+ vpblibdir=${VPB_DIR}/lib
+ else
+ vpblibdir=${VPB_DIR}
+ fi
+ LIBS="${LIBS} -L${vpblibdir}"
+ CPPFLAGS="${CPPFLAGS} -I${VPB_DIR}/include"
+ fi
+ LIBS="${LIBS} -lvpb -lpthread"
+ AC_LINK_IFELSE(
+ [
+ AC_LANG_PROGRAM(
+ [#include <vpbapi.h>],
+ [int q = vpb_open(0,0);])
+ ],
+ [ AC_MSG_RESULT(yes)
+ ac_cv_lib_vpb_vpb_open="yes"
+ ],
+ [ AC_MSG_RESULT(no)
+ ac_cv_lib_vpb_vpb_open="no"
+ ]
+ )
+ LIBS="${saved_libs}"
+ CPPFLAGS="${saved_cppflags}"
+ if test "${ac_cv_lib_vpb_vpb_open}" = "yes"; then
+ VPB_LIB="-lvpb"
+ if test "${VPB_DIR}" != ""; then
+ VPB_LIB="-L${vpblibdir} ${VPB_LIB}"
+ VPB_INCLUDE="-I${VPB_DIR}/include"
+ fi
+ PBX_VPB=1
+ AC_DEFINE([HAVE_VPB], 1, [Define if your system has the VoiceTronix API libraries.])
+ fi
+fi
+
+AC_LANG_POP
+
AST_EXT_LIB_CHECK([ZLIB], [z], [compress], [zlib.h])
# Check for various zaptel features and locations.