aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2008-10-01 23:48:16 +0000
committerseanbright <seanbright@f38db490-d61c-443f-a65b-d21fe96a405b>2008-10-01 23:48:16 +0000
commitbce2530084509073a1f944638d3e897bf7814263 (patch)
tree5c04ed17dc1efad108964d780e94ca5b706a7fd2 /configure.ac
parent0c8cf106ef2b81fddbc9839476f0c666e86bae48 (diff)
Try a test compile using the GMime library. Some distros install gmime-config
in the base package instead of the -devel package. Now we print a notice and disable GMime support instead of bombing during the main compilation. (closes issue #13583) Reported by: arkadia git-svn-id: http://svn.digium.com/svn/asterisk/trunk@145692 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b0dee0f35..337f6aa81 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1437,6 +1437,34 @@ fi
AST_EXT_TOOL_CHECK([GMIME], [gmime])
+if test "$PBX_GMIME" = "1";
+then
+ saved_libs="${LIBS}"
+ saved_cflags="${CFLAGS}"
+ LIBS="${LIBS} ${GMIME_LIB}"
+ CFLAGS="${CFLAGS} ${GMIME_INCLUDE}"
+ AC_MSG_CHECKING(for g_mime_check_version)
+ AC_LINK_IFELSE(
+ [
+ AC_LANG_PROGRAM(
+ [#include <gmime/gmime.h>],
+ [gboolean q = g_mime_check_version(0,0,0);])
+ ],
+ [ AC_MSG_RESULT(yes)
+ PBX_GMIME=1
+ ],
+ [ AC_MSG_RESULT(no)
+ AC_MSG_NOTICE([***])
+ AC_MSG_NOTICE([*** It appears that you do not have the gmime development package installed.])
+ AC_MSG_NOTICE([*** Please install it to include ${GMIME_DESCRIP} support.])
+ AC_MSG_NOTICE([***])
+ PBX_GMIME=0
+ ]
+ )
+ LIBS="${saved_libs}"
+ CFLAGS="${saved_cflags}"
+fi
+
AST_EXT_LIB_CHECK([HOARD], [hoard], [malloc], [])
AST_EXT_LIB_CHECK([FREETDS], [sybdb], [dbinit], [sybdb.h])