aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2008-05-09 16:36:58 +0000
committerfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2008-05-09 16:36:58 +0000
commitaac883fcbc1bf793bf0434eb1e3485e16aaccceb (patch)
tree1ed39851e07244db98d6fb96abe42da0e2ddb94c /configure.ac
parent91c7607101feb19c5f988bcc67ef652a09d45f0b (diff)
Merged revisions 115579 via svnmerge from
https://origsvn.digium.com/svn/asterisk/branches/1.4 ........ r115579 | file | 2008-05-09 13:34:08 -0300 (Fri, 09 May 2008) | 2 lines Improve res_ninit and res_ndestroy autoconf logic on the Darwin platform. ........ git-svn-id: http://svn.digium.com/svn/asterisk/trunk@115580 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 26 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 03d3c3532..15a3f3a44 100644
--- a/configure.ac
+++ b/configure.ac
@@ -263,7 +263,7 @@ AC_FUNC_ALLOCA
AC_HEADER_DIRENT
AC_HEADER_STDC
AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h libintl.h limits.h locale.h malloc.h netdb.h netinet/in.h stddef.h stdint.h stdlib.h string.h strings.h sys/file.h sys/ioctl.h sys/param.h sys/socket.h sys/time.h syslog.h termios.h unistd.h utime.h])
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h libintl.h limits.h locale.h malloc.h netdb.h netinet/in.h stddef.h stdint.h stdlib.h string.h strings.h sys/file.h sys/ioctl.h sys/param.h sys/socket.h sys/time.h syslog.h termios.h unistd.h utime.h arpa/nameser.h])
AC_CHECK_HEADERS([winsock.h winsock2.h])
@@ -491,16 +491,38 @@ AC_LINK_IFELSE(
AC_MSG_RESULT(no)
)
+AC_SEARCH_LIBS(res_9_ninit, resolv)
AC_MSG_CHECKING(for res_ninit)
AC_LINK_IFELSE(
- AC_LANG_PROGRAM([#include <resolv.h>],
+ AC_LANG_PROGRAM([
+ #ifdef HAVE_SYS_SOCKET_H
+ #include <sys/socket.h>
+ #endif
+ #ifdef HAVE_NETINET_IN_H
+ #include <netinet/in.h>
+ #endif
+ #ifdef HAVE_ARPA_NAMESER_H
+ #include <arpa/nameser.h>
+ #endif
+ #include <resolv.h>],
[int foo = res_ninit(NULL);]),
AC_MSG_RESULT(yes)
AC_DEFINE([HAVE_RES_NINIT], 1, [Define to 1 if your system has the re-entrant resolver functions.])
+ AC_SEARCH_LIBS(res_9_ndestroy, resolv)
AC_MSG_CHECKING(for res_ndestroy)
AC_LINK_IFELSE(
- AC_LANG_PROGRAM([#include <resolv.h>],
- [int foo = res_ndestroy(NULL);]),
+ AC_LANG_PROGRAM([
+ #ifdef HAVE_SYS_SOCKET_H
+ #include <sys/socket.h>
+ #endif
+ #ifdef HAVE_NETINET_IN_H
+ #include <netinet/in.h>
+ #endif
+ #ifdef HAVE_ARPA_NAMESER_H
+ #include <arpa/nameser.h>
+ #endif
+ #include <resolv.h>],
+ [res_ndestroy(NULL);]),
AC_MSG_RESULT(yes)
AC_DEFINE([HAVE_RES_NDESTROY], 1, [Define to 1 if your system has the ndestroy resolver function.]),
AC_MSG_RESULT(no)