aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2007-11-17 23:03:16 +0000
committerfile <file@f38db490-d61c-443f-a65b-d21fe96a405b>2007-11-17 23:03:16 +0000
commit6f925e459e2ae4342a5120dc896b966d6f232919 (patch)
treefb5423e54d8c3b7806f85c82d1c687e45a6b3fb4 /configure.ac
parent92145c34baf4977d125e329af6c3067b60db1c09 (diff)
Use autoconf logic to determine the presence of PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP and PTHREAD_MUTEX_RECURSIVE_NP. Enclose error message from network.h in "
git-svn-id: http://svn.digium.com/svn/asterisk/trunk@89394 f38db490-d61c-443f-a65b-d21fe96a405b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b092d7abe..10865e758 100644
--- a/configure.ac
+++ b/configure.ac
@@ -364,6 +364,8 @@ fi
AST_C_DEFINE_CHECK([PTHREAD_RWLOCK_INITIALIZER], [PTHREAD_RWLOCK_INITIALIZER], [pthread.h])
AST_C_DEFINE_CHECK([PTHREAD_RWLOCK_PREFER_WRITER_NP], [PTHREAD_RWLOCK_PREFER_WRITER_NP], [pthread.h])
+AST_C_DEFINE_CHECK([PTHREAD_MUTEX_RECURSIVE_NP], [PTHREAD_MUTEX_RECURSIVE_NP], [pthread.h])
+AST_C_DEFINE_CHECK([PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP], [PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP], [pthread.h])
if test "${cross_compiling}" = "no";
then